home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / app-admin / eselect-opengl-1.0.3 / eselect-opengl-1.0.3.ebuild < prev    next >
Text File  |  2006-04-12  |  3KB  |  96 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild,v 1.7 2006/03/28 18:35:46 vapier Exp $
  4.  
  5. inherit multilib
  6.  
  7. DESCRIPTION="Utility to change the OpenGL interface being used"
  8. HOMEPAGE="http://www.gentoo.org/"
  9.  
  10. # Source:
  11. # http://oss.sgi.com/projects/ogl-sample/ABI/glext.h
  12. # http://oss.sgi.com/projects/ogl-sample/ABI/glxext.h
  13.  
  14. GLEXT="29"
  15. GLXEXT="11"
  16.  
  17. SRC_URI="mirror://gentoo/glext.h-${GLEXT}.bz2
  18.      mirror://gentoo/glxext.h-${GLXEXT}.bz2
  19.      mirror://gentoo/opengl.eselect-${PV}.bz2"
  20.  
  21. LICENSE="GPL-2"
  22. SLOT="0"
  23. KEYWORDS="~alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
  24. IUSE=""
  25. RESTRICT="multilib-pkg-force"
  26.  
  27. DEPEND="app-arch/bzip2"
  28. RDEPEND=">=app-admin/eselect-1.0_rc1"
  29.  
  30. S=${WORKDIR}
  31.  
  32. src_unpack() {
  33.     unpack ${A}
  34.  
  35.     mv opengl.eselect-${PV} opengl.eselect
  36.     mv glext.h-${GLEXT} glext.h
  37.     mv glxext.h-${GLXEXT} glxext.h
  38.  
  39.     # Small bugfix
  40.     sed -i 's/ACTION/action/' opengl.eselect
  41. }
  42.  
  43. pkg_preinst() {
  44.     # It needs to be before 04multilib
  45.     [ -f "${ROOT}/etc/env.d/09opengl" ] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
  46.  
  47.     OABI="${ABI}"
  48.     for ABI in $(get_install_abis); do
  49.         if [ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]; then
  50.             einfo "Removing libMesaGL.so from xorg-x11 profile.  See bug #47598."
  51.             rm -f ${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so
  52.         fi
  53.         if [ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]; then
  54.             einfo "Removing libMesaGL.so from /usr/$(get_libdir).  See bug #47598."
  55.             rm -f ${ROOT}/usr/$(get_libdir)/libMesaGL.so
  56.         fi
  57.  
  58.         for f in ${ROOT}/usr/$(get_libdir)/libGL.so.* ${ROOT}/usr/$(get_libdir)/libGLcore.so.* ${ROOT}/usr/$(get_libdir)/libnvidia-tls* ${ROOT}/usr/$(get_libdir)/tls/libnvidia-tls* ; do
  59.             [[ -e ${f} ]] && rm -f ${f}
  60.         done
  61.     done
  62.     ABI="${OABI}"
  63.     unset OABI
  64. }
  65.  
  66. pkg_postinst() {
  67.     local impl="$(eselect opengl show)"
  68.     if [[ -n "${impl}" ]] ; then
  69.         eselect opengl set "${impl}"
  70.     fi
  71. }
  72.  
  73. src_install() {
  74.     insinto /usr/share/eselect/modules
  75.     doins opengl.eselect
  76.  
  77.     # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
  78.     local MLTEST=$(type dyn_unpack)
  79.     if has_multilib_profile && [ "${MLTEST/set_abi}" = "${MLTEST}" ]; then
  80.         OABI="${ABI}"
  81.         for ABI in $(get_install_abis); do
  82.             # Install default glext.h
  83.             insinto /usr/$(get_libdir)/opengl/global/include
  84.             doins ${WORKDIR}/glext.h || die
  85.             doins ${WORKDIR}/glxext.h || die
  86.         done
  87.         ABI="${OABI}"
  88.         unset OABI
  89.     else
  90.         # Install default glext.h
  91.         insinto /usr/$(get_libdir)/opengl/global/include
  92.         doins ${WORKDIR}/glext.h || die
  93.         doins ${WORKDIR}/glxext.h || die
  94.     fi
  95. }
  96.